Voltar

Compatibilidade com IE 7 e Opera ajustadas!

Em Informativos | 17/03/2010 13:20, atualizado em 17/03/2010 15:47 Infernet Exploder Voodoo

Inicialmente, o from Tatooine estava previsto para ter sua estrutura definida em HTML 5, fazendo uso da última encarnação dessa clássica linguagem de marcação (que na data de hoje ainda está em draft, diga-se de passagem). Todavia, o problemático navegador da Microsoft, Infernet Exploder Internet Explorer, ainda não o suporta, mesmo em sua versão 8.

Assim, resolvi não ignorar uma grande parcela dos usuários da Internet que ainda usam o despadronizado navegador da Microsoft, e implementei o from Tatooine em XHTML 1.1, com leves toques de CSS 3 (os quais igualmente não são suportados pelo IE, sendo substituídos por estilos equivalentes quando aplicável).

(Sinceramente, eu ia ignorar cabalmente os usuários de IE, exibindo uma bela mensagem - ou sermão bíblico - ao navegante indicando o quão podre o navegador é e como ele estaria fazendo um bem à web - e porque não?, à Humanidade - migrando para outros navegadores, como o amado idolatrado salve-salve Firefox, o Chrome, o Safari ou o Opera. Mas aí eu resolvi ser menos religioso bonzinho e polido e só deixei o educado erro 666.)

Anyway, se você usa o IE7 ou o Opera, agora pode deleitar-se com o conteúdo do from Tatooine sem misteriosos erros de layout.

P.S.: como fã de videogames, não irei deixar de fora os navegadores do PlayStation 3 e do Wii. Irei avaliar o estado do site nessas plataformas e analisar possíveis correções a serem aplicadas.

Comentários Ainda não foram postados comentários
Comentar
Campos marcados com * são obrigatórios. Seu e-mail não será exibido.
*
*
*
Captcha *
CATEGORIAS AO TOPO E ALÉM LUGARES PARA IR
Topo

“Just write your code so that changes don't disturb its placid surface.” - Bob Nystrom